RSS Feed
Latest Updates
Jan
15

On January 12, 2016, Microsoft ended support for Internet Explorer versions older than version 11. As a result – and for security purposes – IE users will need to upgrade to version 11 or newer in order for online courses to function correctly. Windows 10 users can still access online courses using Edge.

Compatibility with Firefox, Chrome, and Safari will not be impacted by Microsoft's support changes.

If you are currently using a version of Microsoft IE older than 11, please be sure to update your browser to avoid any disruptions in your ability to access online courses.

Learn more about Microsoft's support updates here, including information on how to update your browser.

 


Read more »



Apr
11
Heartbleed Vulnerability Update
Posted by Monique C on 11 April 2014 04:43 PM

The engineering team at Talance has worked to assess the impact for our customers of the CVE-2014-0160 vulnerability, also known as Heartbleed (https://www.us-cert.gov/ncas/alerts/TA14-098A). This critical vulnerability has affected a large portion of service providers over the internet using OpenSSL.

After our investigation there is no evidence that any user credentials, credit card credentials or user data were compromised among Talance's clients.

Talance is not using a version of OpenSSL having the Heartbleed vulnerability.

If you have any questions or concerns, please visit http://support.talance.com/.


Read more »




Help Desk Software by Kayako fusion